In de oudere versies van Munin Node kreeg ik foutmeldingen, dit is ook weer verbeterd met de laatste updates van FreeBSD Ports, maar om deze informatie weg te gooien vond ik zonde.

 

  1. Ik was nog niet helemaal tevreden, dus draaide het configureren nogmaals:
    # munin-node-configure shell

    Ik kreeg een foutmelding op mysql, ntp, ntp_status, smart_ en tomcat (Non-zero exit during autoconf)





  2. Die van Tomcat snap ik niet, ik gebruik geen tomcat, waarschijnlijk moet ik wat plugins verwijderen:


    Ik ga naar:
    # cd /usr/local/share/munin/plugins
    # ls

  3. Ik gok als ik tomcat verwijder dat de foutmelding weg is.
    # rm tomcat*


  4. En nu controleren:

    # munin-node-configure --shell



  5. MySQL moet wel gemonitort worden, in de volgende thread shijnt Perl-DBI Nodig te zijn: https://mailman.archlinux.org/pipermail/arch-general/2012-September/031058.html


    # cd /usr/ports/databases/p5-DBI
    # make install clean

    Standaard optie selecteren:


    Opmerking: In FreeBSD 10.1 (Of de nieuwere ports) word dit wel automatisch mee geïnstalleerd.

     

  6. Klaar met installeren, meteen controleren met:

    # munin-node-configure --shell

    De foutmelding is veranderd naar: mysql_ Wrong amount of autoconf


  7. We schijnen ook een Cache::Cache module nodig te hebben, dit is beschikbaar via cpan:
    # cpan install Cache::Cache


  8. Mirror site's? < Yes > Please!


  9. Installatie van Cpan Cache::Cache is klaar:


  10. Na controle krijg ik dezelfde foutmelding, ik ga de machine herstarten
    # shutdown -r now

    Er word meer opgestart dan ooit tevoren, best spannend, ben al zover en zou zonde zijn als er iets faalt:



  11. DBD::mysql not fully installed?
    # cpan install DBD:mysql


  12. Dit alles laat ik even zoals het is, ik hernoem de mysql_plugin
    # mv mysql_ mysql_.bak



  13. We schakelen smart_, ntp_, ntp_states uit. Ik heb al monitoring via de hpt tool

    # mv smart_ smart_.bak
    # mv ntp_ ntp_.bak
    # mv ntp_status ntp_status.bak

  14. Start munin met /usr/local/etc/rc.d/munin-node start, kom ik er achter dat het munin_node_enable="YES" moet zijn:



  15. Nu werkt munin_node wel!
    # /usr/local/etc/rc.d/munin-node start


Tot zover het uitstapje naar de foutmeldingen binnen Munin, dit geeft wel meteen een beetje inzicht hoe je het een en ander kan troubleshooten en waar de paden zich ongeveer bevinden.